Results 1 to 5 of 5
  1. #5
    Senior Member
    Join Date
    Aug 2007
    Age
    67
    Posts
    11,816
    Post Thanks / Like

    Re: Honda 75 HP rough at idle **Update**

    Quote Originally Posted by cammy View Post
    Ran the boat Friday and Saturday with 2 cans of seafoam in the gas tank. No issues at all. Must have had some water or a gummed up jet that caused the issue. Do have some oily crud draining from the airbox drain but not a lot. Looks like the seafoam is doing its thing to clean out the carbs.
    Seafoam is a real fixer, I have used it in yard equipment as well. I think that varnish is over rated in many cases I just think it is old gas. I try to empty all of the vehicles before winter and re-fill each of them and then put in the Marine Stabil because of the required alcohol additives which have moisture added. So far it works and I have 49 gallons of storage gas for generators that I use up in the season, then re-fill with gas and Stabil Marine..........Jetspray
    2003 Alumaweld, 19'6", Chevy vortec V-6, SD-309 american turbine jet, T-8 Yamaha kicker, waiting for the tackle fairy to show up to fill my boxes

  2. Likes cammy liked this post
  3. #4
    Member
    Join Date
    May 2008
    Posts
    99
    Post Thanks / Like

    Re: Honda 75 HP rough at idle **Update**

    Ran the boat Friday and Saturday with 2 cans of seafoam in the gas tank. No issues at all. Must have had some water or a gummed up jet that caused the issue. Do have some oily crud draining from the airbox drain but not a lot. Looks like the seafoam is doing its thing to clean out the carbs.

  4. Likes Waterdog, nayr liked this post
  5. #3
    Member
    Join Date
    May 2008
    Posts
    99
    Post Thanks / Like

    Re: Honda 75 HP rough at idle

    Already checked the plugs as that was my first thought. Look great. Hoping it is a gummed up idle circuit or sticky float that the seafoam will take care of.

  6. #2
    Senior Member Waterdog's Avatar
    Join Date
    Aug 2009
    Location
    The Twilight Zone
    Posts
    1,745
    Post Thanks / Like

    Re: Honda 75 HP rough at idle

    Could be a thousand different things but the first thing I would check is the fuel filter. Then Id check the spark plugs.
    Hunting, Fishing, Labrador Retrievers and a glass of Forty Creek Barrel Select Canadian Whiskey at the end of the day - Life Is Sweet

  7. #1
    Member
    Join Date
    May 2008
    Posts
    99
    Post Thanks / Like

    Honda 75 HP rough at idle

    Haven't used the boat in a while so Monday I hooked up the muffs and started the engine in the driveway. Went fishing yesterday and everything was fine for the first couple of runs between spots and then the motor started running rough at slow speed and idle. Kicker motor runs off the same tank and runs fine. Thought I caught a wiff of old varnished gas when running at WOT at one point on the lake.

    Can't remember how big the tank is (2001 Hewes Craft) but I put 11 gallons of 91 octane in the tank that morning. Stabil used before parking it last time. Bought a can of seafoam and added it to the tank last night and have not run the motor since. First issue I have had with the motor (original owner) and am hoping it is stale fuel. Will be using it this weekend and am hoping not to have an issue.

    Any thoughts?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •