PDA

View Full Version : Humminbird 768 problem Please help



jaysimu
08-05-2010, 08:41 PM
I bought a humminbird 768 gps combo a few months ago and on my last fishing trip it started messing up. It stopped reading the depth accuratly. If it is 100 feet deep it will read for a minute or 2 but its kinda hasy and doesnt read it good and it blinks then it goes to like 750 feet and sits there for a long time and sometimes it goes back to the right depth and it wont mark fish anymore either. When the bottom should be a black line its kinda a light grey or its black for a minute then it stopes It was working right and i could see the downrigger wieghts and it was marking fish then it just stopped working. PLEASE HELP

Polebrother
08-06-2010, 12:54 AM
You might get more hits/replies if you post this on the "Marine Electronics" thread. Good luck, hope your problem is nothing serious.

Dennis
08-06-2010, 05:59 AM
I don't know Humminbird's but you might try cleaning the transducer. Just use some warm soap and water and maybe a soft scrub brush. On occasion the transducer might pick up some oil or something else that impairs the return signal. I had a similar problem and cleaning seemed to fix the problem.

Hope that helps.

OYD
08-06-2010, 03:49 PM
It is a contact problem that is usually easily resolved by reseating the head into the bracket. Some do it more than others. I have a new 767 and have had it happen. I noted that the metal piece in the bracket did not hold the cables as tightly as the older models and bent the flanges to fit better. Not perfect, but better than before the adjustment. Still find reseating does the trick, though.